Made the jump to Vista

Submitted by Robert MacLean on Mon, 03/26/2007 - 20:21

This past weekend I spent at a management session at the wonderful Crocodile Kruger Lodge. It really is an amazingly beautiful place with the best food I have ever had at a hotel/lodge/guest house. I also had the chance to feed a zebra (as they literally walked right up to the place). While not enjoying that I got to spend considerable time indoors discussing all kinds of things (many hurt my head) that will benefit the company I work for in amazing ways and I am slowly beginning to understand things that don't fit neatly into a try..catch..finally block.

So during this time I took the chance to reinstall my laptop and get Vista on it. First thing I did was pop the DVD into the machine and looked for a way to run the Vista File and Settings Transfer Wizard (assuming it would run on XP and be better than XP's) and easily enough I found it on the splash screen. Interestingly enough it is now call Windows Easy Transfer, which I laughed at since we have moved from FAST to WET ;) (if you didn't get the fact that I'm geeky from the try..catch in the first paragraph, hopefully you are getting it now).

I then ran the XP backup to backup my files (just incase WET has a problem) and dumped it all to an external drive. Next I rebooted and went through the process of installing Vista (complete with formatting hard drive). Once done the machine rebooted and I was greated by the wonderful sight of Vista loading fine.

Now one thing I didn't take was the driver CD for my HP nx8220 laptop so I was a little worried it wouldn't work without it, but it worked perfectly, with the only items not having drivers being the sound card and the smart card reader. Those were easily sorted by using the search online for drivers feature (which never worked in XP, so +1 to Vista).

I then installed all the usual requirements (Office 2007, VS etc...) and realised I need to join to the work domain to get my email. The problem was I was using a wireless network to connect to a co-workers laptop which was sharing a GPRS internet connection (no 3G or ADSL where we were). So I tried the idea of connecting via VPN, and joining the machine to the domain (crazy I know), and it worked! Now to log in, and damn "No logon servers available".

So I logged back into the local account, connected the VPN again, and used the runas command line tool with the /profile option to launch notepad under my domain account (phew thats a long idea), but it means the profile gets copied down to the local machine even under a different account, which meant when I logged out and I could log back in.

And now to restore my profile using WET, and OMG what a better tool. It copied my RSS feeds (Outlook/Windows/IE ones), my Office preferred theme, my custom search providers for IE 7 (and kept Google as my default) and even the command line colours I use! What it didn't copy (which FAST used to) was all my internet and VPN connections, but it is a simple job to do those.

All in all it was an amazingly pleasant and easy to do install.